User Sign-In Issues
Resolved
Mar 23, 2026 at 8:51am UTC
The issue affecting authentication email delivery and user sign-in is now largely resolved.
Over the past several days, we observed significantly reduced email delivery rates, which led to failed sign-in attempts and temporary account lockouts. Since March 20th, delivery and sign-in success rates have returned to normal levels across all major providers.
Notably:
Apple iCloud email delivery has recovered from ~20% to near 100%
Corporate and Microsoft 365 domains have returned to expected levels (92–100%)
Overall sign-in success rates are now consistently above 95%
We are now seeing only a very small number of isolated cases, compared to the elevated failure rates earlier in the incident.
We believe the issue has been mitigated through a combination of Microsoft-side improvements and adjustments made to our sign-in controls.
We will continue to monitor closely, but at this stage the incident can be considered largely resolved.
Thank you for your patience while we worked through this issue.
Affected services
Updated
Mar 21, 2026 at 8:03am UTC
While we continue working with Microsoft on the underlying email delivery issue, we have implemented adjustments to our sign-in security settings to reduce the likelihood of users being temporarily locked out.
These changes are designed to provide a smoother sign-in experience while maintaining account security.
If you are still experiencing issues accessing your account, please contact your internal IT team for assistance.
We will continue to provide updates as we work toward a full resolution.
Affected services
Updated
Mar 19, 2026 at 4:30pm UTC
We’ve identified that, for some customers using Microsoft services, authentication emails (including sign-in and password reset emails) may be held in Microsoft’s security systems.
If you are not receiving these emails, we recommend contacting your internal IT team, who can review and release any held messages.
For customers who manage their own IT, you may be able to check your organisation’s quarantine via the Microsoft Security portal: https://security.microsoft.com/quarantine
We are continuing to work with Microsoft to resolve the underlying delivery issue and prevent further disruption.
Thank you for your continued patience while we work toward a full resolution.
Affected services
Created
Mar 19, 2026 at 2:01pm UTC
We are currently investigating an incident affecting user sign-in.
Since March 17th, some users have been unable to receive sign-in or password reset emails, which has prevented successful authentication. Repeated sign-in attempts have, in some cases, triggered automated security protections, resulting in temporary account lockouts.
We are actively working with Microsoft to resolve the issue, restore email delivery, and ensure affected users can safely regain access to their accounts.
We understand how disruptive this is and appreciate your patience while we work toward a resolution. Further updates will be provided as soon as more information becomes available.
Affected services